Issue:
Screen freezes on "Connecting to your Computer" when connecting to your machine from the Softdrive App.
Causes:
- SoftdriveClient.exe being blocked by Firewall/Antivirus/IP Restriction.
In order for Softdrive to fully operate there needs to be open communication from the softdrive app in your computer (SoftdriveClient.exe) to the Softdrive server in the Virtual Machine (SoftdriveServer.exe). Whenever there is firewall/Antivirus/EDR blocking the necessary ports or blocking the SoftdriveClient.exe on the local computer side, you will see the screen above.
Solution:
Confirm with your IT department that there has not been any change that may affect or block softdrive operation. This includes antivirus/EDR policies that may be blocking the Softdrive client App(softdriveclient.exe), or firewall policies that may be blocking the necessary ports for softdrive to operate.
Make sure there that none of these is happening:
- SoftdriveClient.exe is blocked by a Firewall.
- Necessary ports for Softdrive not being opened.
- Antivirus/EDR software blocking Softdrive.
Please use the following links to confirm your Softdrive app is well configured.
Windows Firewall Configuration
*If there is another program managing your computer firewall make sure SoftdriveClient.exe is allowed.